LIGHTKEY

TYPING.REDEFINED

Lightkey's Technical Support Guide

Support Request: | can't see predictions when | type

Resolution Procedure

1. Did you restart your device after the installation?
Why is this important? As part of its installation Lightkey registers several services on the device. These
services are best detected following a full restart, especially services connected to Microsoft Office.

- Recommended Action: Restart your computer following Lightkey's installation.

2. Is your license valid?
Why is this important? Lightkey Professional is a subscription-based software and as such it requires a
valid license.

- Recommended Action:
Open Lightkey's Control Center / License tab, and make sure your license is valid (see below image).
For Lightkey Pro/Pro AT Editions:

@ Accessibility settings

% B License @ About

Dashboard
Lightkey Pro AT Edition

License #35154361

1 Device

Productivity Metrics

Prediction Profile

USE LIGHTKEY ON ALL YOUR PCs

Preferences / Discounted price
/ Lifetime updates included

¥ License(s) can be migrated

License LIGHT LET'S GO

For Lightkey Business/Business AT Editions:

© All rights reserved Lightkey Sources Ltd. 2022 Page 1 of 13



’L @ About B License

Dashboard .
Lightkey Business Edition Lightkey for Home and Small Office

@ Licensed to ‘My Organization’

6 Activated / 25 Allowed Devices Buy Lightkey Professional
Productivity Metrics

Lightkey for Business

Prediction Profile Sync License

13

Preferences

@ Coming Soon...

Learn More

3. Did you make sure the required application is activated?

Lightkey's predictions are natively integrated into the following applications: MS Office Word, Outlook,
PowerPoint and Google Chrome Gmail, WhatsApp Web, LinkedIn Messenger, Yahoo! Mail and Outlook
Mail. By default, upon installation all these applications are enabled for predictions and users are not

required to enable them individually. In some cases, users may accidently disable one or more of the
applications thinking they enabled them.

- Recommended Action: Make sure all required applications are enabled — open Lightkey's

Control Center, under Preferences / Applications — make sure all required applications are
highlighted.
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@®) Accessibility settings

% (" Applications Prediction  (7b] Interaction A&’ Notifications 3 General

Basiass Microsoft Office Applications

“ : W Microsoft Word o ¥ Microsoft Outlook P B Microsoft PowerPoint
SelEnil e Enabled Enabled Enabled

Browser Applications

Prediction Profile

Google Chrome ,ﬁ Microsoft Edge
Extension Installed

Preferences
Lightkey Anywhere

Enable Lightkey Anywhere technology (Alt+Click) ~ Take tutorial Learn more

License v Enable Auto-on technology  Clear history

v Disable Lightkey Anywhere in select applications Manage...

4. Did you select your Lightkey prediction languages?

Why is this important? Lightkey automatically detects the end-user’s installed Windows input
languages and selects them by default when creating the personal prediction profile. Sometimes, users
may use a US keyboard layout to type content in other languages (e.g. German or Norwegian), or
otherwise use a German keyboard layout to type English content. In these cases, the end-user won't
see predictions in the non-installed/non-selected language.

- Recommended Action - step 1: Make sure that all languages used by the end-user are properly
installed as Windows Input languages (through Windows language settings).

- Recommended Action - step 2: Make sure that the user’s languages are properly selected -
open Lightkey’s Control Center and click on the ‘Prediction Profile’ tab.
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@®) Accessibility settings

% Languages Categories € Create Category X Import Settings

Dashboard Prediction Languages

Dutch (NL) English (US) French (FR)

Productivity Metrics Aetive Active Active

Add New Prediction Language

Prediction Profile

Afrikaans Arabic Azerbaijani Bashkir
Preferences

Belarusian Bosnian Breton Bulgarian

lesres Catalan Cornish Corsican

5. Is your Windows keyboard layout matching the language you are using?

Lightkey supports 85 languages and it uses the active Windows keyboard layout to infer the currently
selected language for predictions and spelling corrections. If you are using an unsupported Windows
keyboard layout (for example Japanese or Chinese) to type English content with it, Lightkey won't be

able to work.

In other words, it's highly recommended to use Windows English keyboard to write English content,
Windows French keyboard to write French content, etc.
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6. Do you know how to select predictions suggested by Lightkey?

Why is this important? Selecting Lightkey’s predictions and/or spelling corrections requires a simple hit
on the Tab key. This is relevant when typing in all natively supported applications (Microsoft Office
Word, Outlook, PowerPoint, and Google Chrome Gmail, WhatsApp Web, LinkedIn Messenger, Yahoo!
Mail and Outlook Mail). In any other application, the end-user can invoke Lightkey using the ‘Lightkey
Anywhere' feature which is triggered by holding the ALT key and clicking on the desired input field.

- Recommended Action: Start typing in any of the natively supported applications (see list above)
and hit the Tab key when the suggested prediction fits. In any other application, simply hold the
ALT key before clicking on the desired input field to trigger Lightkey Anywhere.

7. Do you have a multiple-displays setup?

Why is this important? Lightkey's predictions may not appear correctly (i.e. not in line with your text) in
cases where a single device is connected to an outside display/multiple displays, each configured with
a different scaling factor. In order to resolve this issue, we follow Microsoft's recommendation to adjust
your display settings so all connected displays are configured with the same scaling factor. In order to
do that, please follow the next steps:

- Recommended Action - step 1: right-click anywhere on your desktop background and select
Display settings. Alternatively, you can go to Windows Start > Settings > System > Display.

- Recommended Action - step 2: Look for "Change the size of text, apps, and other items"
and adjust it for each monitor so that all monitors use the same scaling factor (see below image).
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Display Display Display
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8. Is Lightkey’s Office Add-in enabled?

Why is this important? As part of its installation Lightkey registers an Office Add-in in Word,
PowerPoint and Outlook. This Add-in is set to be enabled by default. In some rare cases, the Add-in
might be turned off.

- Recommended Action - step 1: First, make sure that predictions are working in Lightkeypad
(Lightkey's built-in predictive typing editor) — Open Lightkeypad from Windows Start menu and
make sure that you see predictions as you type. If not, skip to the next section of this guide.

- Recommended Action - step 2: Make sure that Lightkey's Add-in is enabled in Office
applications. Open Microsoft Word, go to File -> Options and Add-ins and make sure Lightkey is
in the Active Add-ins list. If it's not in the list or in case it's listed under the non-active Add-ins,
please move to the next step:

Word Options

G | ot
ener ‘ {" View and manage Microsoft Office Add-ins.
Display
Proofing Add-ins
Save Name Location Type -

Language

Date (XML)
Instant Messaging Contacts (English)

Action
Action

Advanced

Lightkey 19.0 for Microsoft Word il COM Add-in
Customize Ribbon = - = = = -
Measurement Converter (Measurement Converter) C\..rosoft shared\Smart Tag\METCONV.DLL  Action
Quick Access Toolbar Telephone Number (XML) C:\..\microsoft shared\Smart Tag\MOFL.DLL  Action
Add-ins
Trust Center ActionsPane Schema for Add-Ins c\..crosoft Shared\VSTO\ActionsPane3.xsd XML Schema
Microsoft Actions Pane 3 XML Expansion Pack
OneNote Linked Notes Add-In Ci\...icrosoft Office\Office 16\ONBttinWD.dll  COM Add-in

=

OneNote Notes about Word Documents ..soft Office\Office 16\ONWordAddin.dll  COM Add-in

Time (XML) CA.. \microsoft shared\Smart Tag\MOFL.DLL  Action
Add-in: Lightkey 19.0 for Microsoft Word
Publisher: <None>

Compatibility: No compatibility information available

Location: file:///C:\Program Files (x86)\\Lightkey Sources LTD\Lightkey\Lightkey.Applications.Word.vstolvstolocal

Description:

Manage: || COM Add-ins > Go...

‘ OK ‘ Cancel

- Recommended Action - step 3: go to the ‘Manage: COM Add-ins’, click the ‘Go..." button and
make sure Lightkey's box is checked.
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9. Are your Office Add-ins disabled by the Office Trust Center?

Why is this important? As part of its installation Lightkey registers an Office Add-in in Word,
PowerPoint and Outlook. This Add-in is set to be enabled by default. In some rare cases, users (or
Admins) may choose to disable the functionality of ALL Office Add-ins.

- Recommended Action - step 1: Follow all steps recommended in section 8 here-above to make
sure Lightkey's Add-in is enables properly.

- Recommended Action - step 2: Open Microsoft Word, go to File -> Options -> Trust Center
and click on the ‘Trust Center Settings’ button. Go to ‘Add-ins’ and make sure that the ‘Disable
all applications Add-ins’ box is not checked.

(]

File Home Insert Design Layout References Mailings Review View Help Q Tell me what you want to do

j Trust Center

General

Trusted Publishers

Display Add-ins (COM, VSTO and Other)

Trusted Locations
Proofing [] Require Application Add-ins to be signed by Trusted Publisher
Trusted Documents
Save
Trusted Add-in Catalogs

Language i — |
Cr—

Ease of Access
ActiveX Settings

[ Disable all Application Add-ins (may impair functionality)

Advanced
Macro Settings
Customize Ribbon
Protected View
Quick Access Toolbar
Message Bar
Add-ins v
File Block Settings

Trust Center P 5
Privacy Options

b - i + 180%

Pagelof1 0
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10. (I can’t see predictions in Google Chrome / Microsoft Edge) Did you enable Lightkey’s Browser Extension?
Why is this important? As part of its installation Lightkey installs a Browser Extension in the end-user’s
device and requires the user to approve it. Predictions may not appear in Google Chrome until the

extension is approved.

- Recommended Action - step 1: Make sure that predictions are working in Lightkeypad
(Lightkey's built-in predictive typing editor) — Open Lightkeypad from Windows Start menu and
make sure that your see predictions. If not, skip to the section of this guide.

- Recommended Action - step 2: Make sure that Lightkey's Chrome Extension is enabled - open
Google Chrome, open chrome://extensions/ and make sure that Lightkey's Chrome Extension is

enabled.
v X
W Extensions p 3 -
& C ® Chrome | chrome://extensions L x ¥ 0O 0 :
M Gmail i Outook Ba Yahoo Wl Proton P Aol ® Zoho % HubSpot &% Slack [ Medium Q Quora @ Reddit & SO ¢ ClickUp »
= G Extensions Q_ Search extensions Developer mode
Y Google Docs Offline Lightkey - Al-powered Text Prediction
% Edit, create, and view your documents, % Turbocharge your typing with real-time text
spreadsheets, and presentations — all without prediction, grammar & spelling correction
internet access.
Details Remove (@] Details Remove (@]

11.1Is Lightkey's background service running?
Why is this important? Lightkey's service may be stopped due to an unexpected fatal error (e.g.
hardware issues).

- Recommended Action: in order to verify that the service is running, go to Windows Services and
make sure Lightkey's service is in ‘Running’ state. Otherwise, try to start it manually (see image
below).
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chrome://extensions/

File Action View Help
s mEc= Hm »enwn

B B edsHtoitIiiI....SSP P

Lightkey Service Name Description  Status Startup Type Log On As o
1 Lightkey Neural Lightkey Ne... Running Automatic Local Syste...
Start the service *1Lightkey Service
. Local Service
Description: Stop Local Syste...
Lightkey Service Pause Local Syste...
Resume ig... Local Syste...
Restart Local Syste...
ig... Local Syste...
All Tasks 2 ig... Local Service
Refresh Local Syste...
Network S...
Properties ig... Local Syste...
Help Local Service
e wrenwer Local Syste...
Oeee Manual (Trig...  Local Service
V.. Running Manual (Trig... Local Syste...
» Manual Local Syste...
€.e Manual (Trig...  Local Syste...
.. Running Manual Local Service
Running  Automatic Network S...
- Manual (Trig...  Local Syste...
Running  Automatic Local Service
... Manual Local Syste...
Manual (Trig...  Local Syste... Y
Extended /\Standard
Start service Lightkey Service on Local Computer
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Support Request: My VSTO refuses to start while Lightkeypad is working

Resolution Procedure

Make sure add-ins are general enabled in Microsoft Office
In Microsoft Word, go to File > Options = Trust Center and click on Trust Center Settings

Trust Center

Word Options 7 X

G |

enere @ Help keep your documents safe and your computer secure and healthy.

Display

Proofing Security & more

Save )

Visit Office.com to learn more about protecting your privacy and security.

Language

Accessibiity

Advanced Microsoft Word Trust Center
Customize Ribbon The Trust Center contains security and privacy settings. These settings help keep your

n [ Trust center settings.. |

- computer secure. We recommend that you do not change these setiings. Trust Center Settings
Add-ins

[ |

In the Add-ins tab, make sure that all boxes are NOT checked:

Trust Center

S 2 Add-ins (COM, VSTO and Other}
Trusted Locations
1 Require Application Adins to be signed by Trusted Publisher

Trusted Documents

Trusted Addin Catalogs .
_ Disable all Application Add-ins (may impair functionality)

ActiveX Settings

Macro Settings

Protected View

Message Bar

File Block Settings

Privacy Options

Form-based Sign-in

? x

Cancel

Make sure to re-enabled Lightkey’s add-in in case it is listed under the disabled items list
In Microsoft Word, go to File > Options = Add-ins. In the Manage box, change COM Add-ins to Disabled

Add-ins, and then click Go.
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Viord Options 7 X
|

y View and manage Microsoft Office Add-ins |

Add-ins.

b Accesi Tocha Inactive Application Add-ins
:" PrNeoone e ‘ . ‘ “

Document Related Add-ins

Disabled Application Add-ins
ightkey 28.0 for Microsoft Word :///C ram Files (x86)\Li COM Add-in

I.‘“ sge | Disabled items Y I Go

Select the add-in and click Enable. Click Close.

PTRETOMPUF CTEaToT CUNTATONT I TS TCTESTOTRUR PP C VW OTTRATUTT X
\Teleohone Number OXML) G\ Microsoft Shared\Smart Tag
Disabled Items ? X

The items listed below are disabled because they prevented Word from functioning correctly, or
your system administrator has disabled them through Group Policy.

Please note that you may have to restart Word for these changes to take place.

Select the ones you wish to re-enable.

Trust Center itkey 28.0 for Microsoft Word file:///C:\Program Files (x86)\Lightkey Sou COM Add-in

Add-ins

Enable | Close
[vstolocal  COM Ad|

NordAddin1/WordAddin1/bin/Debug/WordAddin

Make sure that the local Antivirus software is temporarily disabled
For example, if you have Avast Antivirus on your machine, by right clicking on its tray icon you can
temporarily disable it for 10 minutes.

Open Avast user interface
Avast shields control

Disable for 10 minutes Silent Mode

Quarantine

Disable for 1 hour

Disable until computer is restarted Update

Disable permanently Registration information
About Avast

Make sure that the load behavior of the VSTO is set to 3 while Office apps are opened
After MS Word, Outlook and PowerPoint are opened, set the following registry values to 3:

1. SOFTWARE\Microsoft\Office\Outlook\Addins = LoadBehavior=3
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2. SOFTWARE\Microsoft\Office\Word\Addins = LoadBehavior=3
3. SOFTWARE\Microsoft\Office\PowerPoint\Addins = LoadBehavior=3

Remote session diagnosis

Collecting information about the add-in loading failure
1. Go to Options > Advanced = General and check the “Show add-in user interface errors”

Word Options ? x
General 4 Allow background saves [=]
Display
Procfing Preserve fidelity when sharing this document: | Document1 -

Save [[] save form data as delimited text file
Language B Embed linguistic data
Accessibility General

Advanced

H

[ Confirm file format conyersion on open

Customize Ribbon M Update automatic links at open

Quick Access Toolbar ["] Allow opening a document in Draft view
Add-ins
Trust Center B Ehow add-in user interface errors|

[] Always open encrypted files in this app
[] Always use this app to coauthor files

Mailing address:

File Locations.. Web Options...
Layout options for: | ¥7 Document1 -

[[] Add space for underlines
[7] Adjust line height to grid height in the table
L_| Allow hyphenation between pages or columns

[] Balance SBCS characters and DBCS characters

2. Set the following environment variables under PATH:
a. VSTO_SUPPRESSDISPLAYALERTS - setto 0
b. VSTO_LOGALERTS - setto 1

Environment Variables x

User variables for FinishLine

Variable Value
OneDrive CAUsers\FinishLine\OneDrive
OneDriveConsumer C:\Users\FinishLine\OneDrive
C:\Users\FinishLine\AppData\Local\Microsoft\WindowsApps;
TEMP C:A\Users\FinishLine\AppData\Local\Temp
T™P C:\Users\FinishLine\AppData\Local\Temp
New... Edit... Delete

System variables

Variable Value ~

PSModulePath 9ProgramFiles3\WindowsPowerShell\Modules;C:\Windows\sy

TEMP CAWindows\TEMP

T™P CAWindows\TEMP

USERNAME SYSTEM

VSTO_LOGALERTS 1

VSTO_SUPPRESSDISPLAYALERTS 0

windir C\Windows v

< >
New... Edit... Delete

Cancel
3. Under Computer\HKEY_CURRENT_USER\SOFTWARE\Lightkey, set VSTO_Debugging to 1
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Still Have Problems? Contact Us

If you encountered a problem that wasn't covered in the tutorial, please contact us here.
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